Produktfilter

Artikel / Produkte, Frontend / Shopbereich Kommentar schreiben

ProduktfilterSie haben so viele Produkte, dass Ihre Kunden ewig blättern müssten, um zum gewünschten Artikel zu kommen? Geben Sie dem User doch die Möglichkeit, Ihre Produkte nach frei definierbaren Kriterien zu filtern und ermöglichen Sie ihm eine gezielte Suche nach seinem Wunschartikel.

Die Filterkategorien bestimmen Sie selbst im Adminbereich. In dieser Version können Ihre Kunden mittels Checkboxen mehrere Kriterien miteinander kombinieren.

Produktfilter Produktfilter Produktfilter
Produktfilter Produktfilter Produktfilter

Autor: Sebastian Schramm & Daniel Siekiera

Dateigröße 212,4 KiB - Downloads bisher 2.452
  produktfilter.zip

 

Weitere Beiträge, die Dich interessieren könnten

39 Kommentare bei “Produktfilter”

  1. vocke

    Hallo zusammen… Wir haben das ganze noch erweitert… Leider haben noch nicht alle Produkte Ihre Attribute erhalten.. anzuschauen hier http://www.capking.de/product_filter_pro.php/advanced_filter. Wer Interesse hat bitte ne Mail an uns. Ich werde es an unseren Programmierer weiterleiten…

  2. Jonathand Mocher

    Gerade nach einer solchen simplen, aber nützlichen Idee bin ich auf der Suche. Vielen Dank!

  3. Daniel Siekiera

    Na da hab ich ja was schickes geschrieben… ^^

    Viel Spaß damit.

  4. Daniel

    Hallo,

    Super Modul,

    @vocke
    was habt ihr denn noch erweitert?

    ist das Modul vergleichbar/dasselbe wie von Webdesign-Erfurt?

    Vielen Dank
    Daniel

  5. Daniel Siekiera

    Ich war früher bei Webdesign Erfurt.
    Dort kann keiner Module schreiben, das war immer ich und ja, dass ist das gleiche. Webd Ef hat einfach eine Kopie meiner Arbeiten behalten.

  6. Clever

    Sehr schön :) aber… es gibt keine UND Abfrage wenn man mehrere Caps auswählt … will sagen sucht man HUT und Fliegermütze (weil man beides ansehen will) liefert er weder das Eine noch das Andere …
    Also so gesehen müsste man für eine Suchkategorie eine UND-Abfrage einsetzen, bei verschiedenen Kategorien dann wieder eine ODER-Abfrage.
    Auch wird es harte Arbeit 6.000 (und mehr) vorhandene Artikel umzurüsten.. wäre cool gewesen wenn man dies mittels einer Übersicht auf einzelne Kategorien im Schnellverfahren anpassen könnte – also bereits bestehende Artikel einfach und schnell einfach nur mit den Häkchen an der richtigen Stelle nachrüsten könnte ohne jeden einzelnen Artikel erst aufrufen zu müssen.
    So – sonst macht es einen super soliden Eindruck – herzlichen Dank fürs Teilen :)

  7. vocke

    @Clever
    da haste recht, werden wir mal nacharbeiten. Sobald es soweit ist werde ich bescheid geben. Danke für den Kommentar.

  8. Kehrer

    Dann funktioniert dies auch mit commerce-seo?
    Weil ein anderes Modul nicht gefiltert hat.

  9. Kehrer

    Funktioniert dies nur bei den neuen Produkten oder wie kann ich es bei den bestehenden Artikel schon anzeigen lassen?
    Die Produktmerkmale gibts ja schon.

  10. Daniel

    Hallo Kehrer,

    welche Produktmerkmale meinst du bzw. wie wurden diese eingegeben?

    Daniel

  11. Kehrer

    @daniel
    Na die Attributmerkmale im Admin.
    da habe ich ja die Größen, Farben usw. schon angelegt.
    Kann man diese nicht von da aus generieren?

  12. Daniel

    @Kehrer
    ich denke bei dieem Modul werden nicht die eingegebenen Werte für die Variationen benutzt und gefiltert, sondern die selber angelegte Merkmale.(gibts aber auch)
    Du kannst Merkmale selber anlegen und dann dem gewünschten Produkt zuordnen.
    So hab ich´s verstanden.

  13. Till

    Kann man das auch bei den Kategorien in der Mitte einbauen?

  14. Kehrer

    @Daniel

    Tja schon aber wenn man über 1000 Artikel hat und alle dann neu ergänzen muß ist dies so nicht benutzbar

  15. Daniel

    das wär natürlich noch besser

  16. Daniel

    @Kehrer
    das stimmt,dann schau die die Attributfilter von Southbridge oder Alkim Media an.

  17. Ibo

    Hy Leute,

    kann es sein, das dieses Modul mit einem Anderen kolidiert?
    ich habe verschiedene Module am laufen, die Installation von diesem Modul hat super funktioniert. aber sobald ich im Frontend auf einen Filterbegriff klicke kommt nur eine weisse Seite… keine Fehlermeldung, einfach nur nichts…

    kann mir jemand helfen bitte
    Grüße
    Ibo

  18. Daniel

    @Kehrer
    oder evtl. den AttrFilter, vom xtc-modified Forum

  19. Kehrer

    @Ibo
    mit welchen soll es kollidieren–weiße Seite hat meistens ein falschen Einbau als Ursache.
    Link?

  20. Ibo

    @Kehrer,

    ich habs off gestellt, wo fin dich deine eMail dann sende ich die die modifizierten Daten, wenn du möchtest.

    Gruß
    Ibo

  21. Clever

    nun hats mich auch erwischt – eingebaut und festgestellt das ich meine Artikel nicht mehr sehen kann…
    daraufhin wieder ausgebaut und meine (bereits eingepflegten) artikel bleiben unsichtbar ( sind aber in der DB zu sehen

  22. poli

    Tolle Funktion, nur leider funktioniert die ODER-Abfrage nicht. Beide Radio-Buttons arbeiten nur im UND-Modus bei der erweiterten Abfrage.

  23. TomS

    @poli,

    genau das gleiche Problem hab ich auch…

    Ich glaube, das hängt irgendwie mit der Session zusammen. Irgendwie wird der Session-Parameter “verbinder” (zu sehen per MySQL unter sessions > value), der in der Session die Suchmethode markiert, nicht aktualisiert! Der sollte, je nach dem, welchen Radio button man geklickt hat, entweder auf “true” oder” false” stehen, aber der steht immer auf “true”…
    Ist das bei dir/euch auch so?

    Grüße
    Tom

  24. poli

    @TomS

    Ja genau so sieht es bei mir auch aus. Der Schalter bleibt auf “true”, egal welchen Button man betätigt, allerdings wird bei der ODER-Verknüpfung im Ergebnis noch eine Grafik gezeigt, die anzeigen soll, welche Bedingung bei dem Treffer zum Erfolg geführt hat. Also muss das “false” ausgeführt werden, aber dann stimmt die Berechnung nicht.

  25. TomS

    @poli

    tja, ist echt schade, denn ansonsten funktioniert es ja echt super… vielleicht liest ja einer der Autoren mal unsere Kommentare und haben ein Herz für arme xtcModifierer! ;-)

  26. poli

    Falls die Autoren mitlesen …
    Der Produktfilter ist in dieser Form für alle Produkte gleich. Habe ich aber mehrere unterschiedliche Kategorien, z.B. Herrenanzüge und Hochzeitsschmuck, dann wäre es schön, wenn man den Filter sensitiv betreiben könnte. Also für jede Kategorie eigene Begriffe, die auch nur bei der jeweiligen Kategorie dann angezeigt werden.

    Und wenn der Bug mit dem ODER-Filter nicht wäre, wäre das eine wunderbare Erweiterung des Shops.

  27. Kehrer

    wenn ich nun ein produkt bearbeite kommt:

    : Invalid argument supplied for foreach() admin/includes/classes/categories.php on line 522
    //Daten einfuegen
    foreach($products_data[‘filter’] AS $filter) xtc_db_perform(‘products_to_filter’,Array(‘products_id’ => $products_id, ‘filter_id’ => $filter));

    warum?

  28. pixelchen

    Wenn ich die datenbank versuche zu importieren bekomme ich immer

    #1064 – You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use…

    was kann ich tun?

    bg,
    Meli

  29. clever

    @Meli….etwas spärliche Info, aber ich vermute mal Du hast die Datenbank nicht erweitert – schau Dir die Anleitung noch mal an und führe die SQL Abfrage durch

  30. Kehrer

    @pixelchen: Und wie willst du die importieren?

  31. Pixelchen

    Danke für die antworten.
    Ich hatte versucht die SQL Befehle einfach im PHPMyAdmin Befehlfenster einzugeben.

    Nun habe ich bei xtcmodified eine andere version der Erweiterung gefunden und die geht.
    Allerdings kann man immer nur ein einziges Attribut wählen.

  32. fx-zone

    Ich dreh gleich durch. Ich habe alles nach Anleitung installiert und auch die Datenbank mit den Infos gefüttert. Leider bekomme ich nur noch folgenden Datenbank-Fehler angezeigt:

    1146 – Table ‘usr_xxx_2.TABLE_PRODUCT_FILTER_CATEGORIES’ doesn’t exist

    SELECT id, titel FROM TABLE_PRODUCT_FILTER_CATEGORIES WHERE status = 1 AND language_id = ‘2’ ORDER BY position ASC

    Wo liegt der Fehler?

  33. fx-zone

    Hat denn niemand eine Idee zum dem Problem. Mein Wissen zu Datenbanken ist leider stark begrenzt.

  34. Kehrer

    Table ‘usr_xxx_2.TABLE_PRODUCT_FILTER_CATEGORIES’ doesn’t exist

    steht doch eigentlich da . Die Tabelle in der DB wurde nicht erstellt.
    SQL nicht ausgeführt?

  35. gerald12

    Hallo,
    Super-Modul, ich habe aber ein Problem mit der Schnellauswahl: Ich habe eine Kategorie mit 5 Kriterien angelegt und es gibt auch Artikel in diesen 5 Kriterien. Trotzdem werden immer nur Artikel mit Kriterium 3 angezeigt, auch wenn ich z. B. Kriterium 1 anklicke. Gibt es vielleicht Konflikte mit anderen Modulen …
    Vielen Dank

  36. Spacebon

    Hallo,
    super Modul – vielen Dank.
    Ich habe nur folgendes Problem: Wenn ich “Erweiterter Filter” anklicke werden mir alle Filtermöglichkeiten angezeigt. Bei entprechender Auswahl (Haken setzen) und “suche” erhalte ich eine weisse Seite (Contentseite). Wenn ich auf “Erweiterter Filter” klicke, dann die Chronik (Firefox) vom Browser löschen, eine entsprechende Auswahl (Haken) treffe und auf “suche” klicke erhalte ich die entsprechenden Produkte. Ich muss also jedesmal bevor ich den “Erweiterten Filter” nutzen kann die aktuellste Chronik löschen sonst erhalte ich keine Suchergebnisse.

    Hat jemand eine Idee ????

    Vielen Dank

  37. Spacebon

    Hallo, das erste Problemchen (weisse Seite bei erweiterter Filter) kann man ungehen indem man in den XTC Cache Optionen Cache benutzen auf “false” setzt. Leider habe ich seit der Umstellung nun das Problem dass die Auswahl “ein Kriterium muss zutreffen” keine Ergebnisse mehr anzeigt (vorher hat diese Funktion funktioniert > auch ein zurückstellen der Cache Option brachte keinen Erfolg).

    Also “alle Kkriterien müssen zutreffen” klappt, aber “ein Kriterium muss zutreffen” gibt keine Suchergebnisse aus sobald man mehrere Kriterien auswählt bzw. eines der ausgewählten eben nicht zutrifft. Schade !

    Gibt es hierfür ggf. bereits Lösungen ??

    Vielen Dank

  38. Spacebon

    Lösung für folgende Probleme:

    Weisse Seite wird ausgegeben (keine Suchergebnisse) = XTC Cache Optionen (Cache benutzen) auf “false” stellen.

    UND/ODER Funktion (“alle Kriterien müssen zutreffen” | “ein Kriterium muss zutreffen”) funktioniert nicht = in der product_filter.php ca. Zeile 69 (“$_SESSION[‘verbinder’] = ‘true';”) das “true” entfernen (“$_SESSION[‘verbinder’] = ”;”).

    So klappt der Filter bei mir 100%tig.

    Grüße

  39. CyberAndi

    Hi,
    ich hab vor mit das xt:Commerce 4.1 Start zu installieren.. Kann ich da dann auch diesen Produktfilter dafür verwenden???

    LG

Kommentar schreiben

Hier findest Du Platz für Deine Meinung, Dein Lob, Deine Kritik. Bitte nutze diese Funktion nicht für Supportanfragen! Wenn Du Fragen zu Modulen, Fehlermeldungen oder ähnliches hast, bist Du in unserem eCommerce-Forum herzlich willkommen.

© 2005 - 2015 by xtc-load.de