Blog für xt:Commerce

Frontend / Shopbereich Kommentar schreiben

Blog für xt:CommerceMit dieser Erweiterung für xt:Commerce haben Sie die Möglichkeit in Ihrem Shop einen Blog aufzubauen. So können Sie zum Beispiel Ihren Kunden zusätzliche Informationen zu Produkten zu vermitteln. Mit diesem Modul entfällt die Installation eines weiteren WordPress-Blogs.

Das Tool ist voll administrierbar, bietet einige kleine Features, und wird von AJAX unterstützt, was die Bedienung für den Kunden denkbar einfach macht.

  • Individuelle Metatitel, Metadescription und Metakeywords für jede einzelne Kategorie und jeden einzelnen Beitrag
  • Mehrsprachigkeit – Für alle installierten Sprachen können Meta Angaben, Überschriften und Texte eingetragen werden
  • Zuschaltbare Kommentarfunktion – Ihre Kunden können die Beiträge kommentieren
  • Zuschaltbare Captcha Abfrage für die Kommentarfunktion
  • Sie können einzelne Kommentare als Admin im Frontend löschen
  • Sie entscheiden ob der Kunde registriert sein muss, um einen Kommentar zu schreiben
  • Zuschaltbare Bewertungsfunktion
  • wenn gewünscht, Sessionsperre für Bewertung zuschaltbar
  • Zuschaltbare Social Linkbar um den Beitrag direkt bei den entsprechenden Diensten zu verlinken
  • Zwei Arten von Menü’s für die Box im Shop – jQuery
  • Sie enscheiden wie lang der Beitrag in der Übersicht sein soll
  • volle DirectURL v3 Unterstützung

Blog für xt:Commerce Blog für xt:Commerce Blog für xt:Commerce Blog für xt:Commerce Blog für xt:Commerce

Vergleiche auch mit WordPress in xt:Commerce integrieren

Autor: Webdesign Erfurt

Dateigröße 627,4 KiB - Downloads bisher 2.590
  blog_v11.zip

 

Weitere Beiträge, die Dich interessieren könnten

86 Kommentare bei “Blog für xt:Commerce”

  1. McHower

    Danke für das tolle Modul! Die Einbindung war sehr einfach, lediglich das Design der Box muss individuell angepasst werden. Super und vielen Dank.

  2. Udo

    Hallo Leute,
    ich kämpfe nun schon eine Weile mit diesem Modul. Es funktioniert nun soweit auch. Ich habe nur ein Problem damit:
    man kann keine Kommentare absetzen, wenn man angemeldet ist. Als Gast bzw. Besucher funktioniert es.
    Hat einer eine Idee?
    viele Grüße
    Udo

  3. Franz Schinagl

    Hallo

    Habe das Modul jetzt installiert, jedoch habe ich doch
    einige Schwierigkeiten damit:

    1) es können keine Kommentare abgegeben werden
    2) die ganzen Link zu Google tec. zeigt es mir nicht an.
    3) Bewertung können auch nicht abgegeben werden

    zu sehen ist das ganze unter http://www.SlotCar-Shop.at

    Wäre Euch sehr dankbar für Hilfe.

    FS

  4. Udo

    Hallo Franz,
    Du hast auf jeden Fall die stylesheet Datei falsch eingebunden, die taucht im body Bereich auf, das habe ich gerade gesehen. Da solltest Du noch mal gucken. Das musst Du so — @import url(blog.css); — in Deine tempaltes/Dein Template/stylesheet.css Datei einbauen, nur ohne die Bindestriche..

    Grüße

    Udo

  5. Franz Schinagl

    Hallo Uwe

    Vielen Dank für Deinen Tipp.

    Genauso habe ich Sie eingefügt.
    Muß ich anstatt “url” den Pfad angeben ??

    Habe wie in der Beschreibung und auch wie Du es
    in die template/stylesheet.css eingefügt unf hochgeladen !

    LG
    Sloti

  6. Mike

    Hallo,

    Ich habe das Modul eingebaut und im Frontend funzt es auch ganz gut allerdings finde ich im Backend nirgendwo ne Möglichkeit wie ich den Blog Administrieren kann! Also keine zusatzt Buttons oder ähnliches!
    Benutze den xtcModified!

  7. Mike

    Habe gerade gesehen das ich aus Versehen den eintrag in der “columms_left.php” vergessen hatte dadurch kein Admin Button.

    Somit läuft alles super!

    Allerdings gibts noch ein Problem:
    Wenn ich im Frontend auf ein Thema klicke dann passiert das:

    1140 – Mixing of GROUP columns (MIN(),MAX(),COUNT(),…) with no GROUP columns is illegal if there is no GROUP BY clause

    SELECT blog_id, vote_nr, SUM(vote_nr) AS votes_gesamt FROM blog_vote WHERE blog_id = ‘2’

    Leider weiß ich da dann auch nicht weiter!
    Wie kann ich das beheben???

    Danke
    LG Mike

  8. Franz Schinagl

    Hallo Mike

    Du mußt Dir Deine Admin REchte erst freigen/aktivieren.

    Klicke auf Kunden –> dann Dein Name –> und aktivere dann das Häkchen bei “blog”.

    Somit hast Du es im Admin Bereich.

    *****
    Noch zu meinem Problem:
    Die CSS Datei ist richtig eingebaut, denn eine
    Änderung im Style wird auch gleich übernommen, somit ist sie richtig eingebaut.

    Aber ich bring das Modul nicht zum laufen ***grrrrrr

  9. Udo

    Q Mike

    Ich habe die Bewertungsfunktion abgeschaltet, dann ist die Fehlermeldung weg. Dort steckt der Fehlerteufel drin. Damit kann ich aktuell leben.

    Grüße Udo

    Udo

  10. Thorsten

    Hallo zusammen, ich bin schon ewig auf der Suche nach so einem Blog. Ich weiß allerdings nicht genau wie ich die Box bei einem Gambio-Shop einbinden soll. Kann mir da jemand bitte helfen?

    Danke
    Thorsten

  11. Udo

    Hallo Franz Schnagl,

    schau mal bitte in Deinen Quellcode. Deine normale Stylesheet Datei ist sogar mehrfach mindestens 2 mal im body Bereich eingebunden, die gehört aber in den Headbereich. Weiterhin ist der Javascriptteil des Blogs unvollständig. Der ganze accordion.js Bereich fehlt. Überprüfe Deine Installationsanleitung speziell in templates/DeinTemplate/javascript/general.js.php, dann funktioniert es wenigstens ohne Bewertungen.

    Grüße

    Udo

  12. web-netz

    Also wir haben das Blogmodul bei einem Kunden ausprobiert und müssen sagen, dass wir mit dem Ergebnis sehr unzufrieden sind. Wir empfehlen eher die Verwendung eines ausgereiften Blogsystems (wie z.B. WordPress), welches auch recht problemlos in einen xt:Commerce Shop integriert werden kann.

  13. Franz Schinagl

    Hallo nochmals an Alle

    Ich habe jetzt zum 5ten die Installation kontrolliert,
    und jetzt habe ich den Fehler gefunden.

    Trotz einer Brille dürfte ich ein Blindes Huhn sein :-)
    Habe den Quellcode in die application_top.php nicht eingefügt.

    Jetzt funktioniert alles einwandfrei.

    Nochmals Vielen Dank für Eure Tipps und Unterstützung.

    LG
    FS

  14. Franz Schinagl

    Hat schon jemand eine Lösung für die Bewertung gefunden.

    Es wäre doch Interressant woran es scheitert !

  15. Marcus

    Danke für das tolle Modul! Die Einbindung war sehr einfach, lediglich das Design der Box muss individuell angepasst werden. Super und vielen Dank.

  16. Jörg

    Das Bewertungsproblem lässt sich in der blog_rate.php lösen.

    suche Zeile 50:

    $rating_stars_query = xtc_db_query("SELECT blog_id, vote_nr, SUM(vote_nr) AS votes_gesamt FROM blog_vote WHERE blog_id = '".$blog_id."'");

    und ersetze hiermit:

    $rating_stars_query = xtc_db_query("SELECT blog_id, vote_nr, SUM(vote_nr) AS votes_gesamt FROM blog_vote WHERE blog_id = '".$blog_id."' GROUP BY vote_nr");

    Viel Spaß!

  17. Franz Schinagl

    Vielen Dank Jörg

    Jetzt funktioniert auch das Bewertungsmodul

  18. I-SEO

    Danke Jörg, wollte grade auf das neues Thema einleiten, aber mein Problem ist damit auch gelöst. Also nochmal thx.

  19. Jörg

    Dafür nicht ;-)

    Gruß Jörg

  20. siekiera

    Den Fehler mit dem “GROUP BY” hatte ich eigentlich schon vor einer ganzen Weile behoben. Demnach ist das Modul nicht auf dem neustem Stand.
    Soll übrigens kein Blog Ersatz sein, sondern nur eine Erweiterung des Shops.

  21. ibo

    wollte mich nochmals bedanken für dieses Modul, besser als das WordPress.
    Aber wordPress eignet sich als eine reine Blogseite und nicht als zusatz-Modul…

    mfg
    Ibo

  22. bert

    Vielen Dank für dieses tolle Modul! Leider kollidiert das Blog modul mit der Lightbox. Somit heißt es bei mir (www.s-i-l.de) entweder kommentare hinzufügen können oder Produktbilder nett vergrößert anzeigen können. Hat vlt. jemand ein Idee, woran das liegen könnte?

  23. siekiera

    Ja, mach einen No-Conflict beim jQuery rein, das reicht aus.
    Ich hab in meinem Shopsystem 3 Javabibliotheken parallel laufen. Läuft super.

    Auf meiner Seite ist übrigens auch schon eine Archivfunktion enthalten ;).

  24. bert

    Danke schonmal für die schnelle Antwort. Leider bin ich auf dem Javascriptgebiet absoluter Neuling… Kannst du mir das mit dem No-Conflict vlt. kurz erläutern? Das wär echt super…

  25. Chris

    no-conflict beim iquery rein???
    Kann das mal jemand genau erklären??
    Seit ich das Modul eingbaut habe funktioniert die Lightbox nicht mehr!!
    Wie behebt man den Fehler???

  26. Thorsten

    Hallo,
    bin dabei das Blog zu installieren. Es scheint soweit auch alles zu funktionieren. Nur kriege ich dir box nicht in das Template. Bei Gambio werden die Boxen etwas anders im Template eingebunden, ich weiß aber nicht wie.
    Hilfe

    Thorsten

  27. Thorsten

    Ups… Das mit der Lightbox geht wirklich nicht mehr… scnief.. Ich kann leider nicht genug js um das selber zu lösen. Hat jemand eine Lösung dafür?

  28. Steffen

    Hallo,

    danke für den Blog. Das Modul ist echt super.
    Mir sind allerdings ein paar kleine Dinke aufgefallen, die das Modul sicher noch besser machen würden:

    1.
    Man kann leider einer Kategorie keinen Text bzw. Bild zuweisen. Ich würde mir wünschen, dass beim Klick auf eine Blog-Kategorie z.B. die Beschreibung der Kategorie im Contentbereich erscheint, gefolgt von der Auflistung der Themen.

    2.
    Wenn man das animierte Menu aktiviert, erscheint beim Klick auf eine Kategorie nicht deren Inhalt im Contentbereich. Soll dass so sein?

    3.
    Wenn das animierte Menu deaktiviert ist, werden ja alle Kategorien komplett ausgeklappt dargestellt. Schöner wäre, wenn auch erst beim Klick auf die jeweilige Kategorie die jeweiligen Themen angezeigt werden würden (per CSS, vielleicht im Admin einstellbar)

    Gruß.

    Steffen

  29. Thorsten

    Hallo zusammen,
    ich habe das Problem mit der Lightbox hinbekommen. Für alle sie es auch mal ausprobieren wollen: Einfach in der template/TEMPLATENAME/general.js.php die Zeile

    <script src="/javascript/jquery-1.2.6.js" type="text/javascript">

    auskommentieren, bzw. löschen.

    Gruß
    Thorsten

  30. bert

    Danke Thorsten. Einfacher geht’s wirklich nicht.

  31. Thorsten

    Hallo Bert,

    kein Problem. Gern geschehen…

    Gruß
    Thorsten

  32. Chris

    @lightbox—Zum Beitrag von Thorsten

    Bei mir funktioniert es jetzt auch, allerdings mußte ich den Einstellungen des Blogs das “animierte Blog Menü” auf Nein setzten!!!

  33. Markus

    Hallo, habe das Modul auch grade installiert, nur weiß ich noch nicht so ganz wo die Startseite erscheint.

    kann da jemand mit einem Tip helfen?
    Mein System

    XTC-Modified 1.04

  34. Thorsten

    Hallo Markus,

    deine Startseite: http://www.heels4all.de/blog.php

    Gruß
    Thorsten

  35. Markus

    Hallo Thorsten, vielen Dank für den Tipp. Im Nachhinein eigentlich ganz logisch.
    Funktioniert tadellos.
    Gruß M.

  36. Thorsten

    Hallo Markus,
    kein Problem… Wenn alle Probleme so einfach wären :) Habe mich anfangs auch gefragt wo wohl die Startseite steht… Naja.. manchmal ist es zu logisch… lol..

    Thorsten

  37. katja

    ich bin ein absoluter neuling und hab eine blöde frage. Die Ordner img und shop schmeise ich die einfach ins hauptverzeichnis? danke für ein feedback.

  38. Thomas

    @Katja
    Nö! Den Ordner /img/ kannst Du, glaube ich ignorieren. Der diente lediglich einer Anleitung bzw Verdeutlichung der Funktionen.
    Den INHALT des Ordners /shop/ musst du entsprechend den Strukturen des Shops verschieben.
    Grüße
    Thomas

  39. Oliver

    kann man in dem Blog auch die 18er Funktion vom Shop integrieren? Über diese Funktion kann man dann nämlich ganz einfach bestimmte Beiträge auch nur einer bestimmten Kundengruppe zugänglich machen.

  40. CHGS

    zum Beitrag von Thorsten bzgl. jquery …

    bei mir lautet der Abschnitt:

    <script src="/javascript/jquery-1.2.6.js" type="text/javascript">

    kann man das ohne weiteres löschen???

    Danke und Gruß Timo

  41. CHGS

    außerdem wäre für mich interessant, wie ich bei zu langen Blogs am Ende “… den ganzen Blog lesen!” einfügen kann mit Link.

    hat dies jemand schon gelöst?

  42. tomjons

    Hallo, tolles Modul.

    Ich habe die Box im “Content-Bereich” eingebunden {$box_BLOG}.

    Ich schaffe ich es, dass diese nur auf der Startseite angezeigt wird?

    Bisher lädt die Box ja auf jeder aufgerufenen Seite (Produktdetails usw.) …

  43. CHGS

    dann hast du {$box_BLOG} direkt unter {$box_maincontent} geschmissen oder?

    ich habe mir eine neue seperate Seite erstellt, auf die dann navigiert wird, finde ich persönlich besser.

    http://www.sound-pressure.de

  44. John

    Hi,
    Thanks for the module!

    Help. How to display a list of new posts from the blog page blog.php?

    Thanks

  45. Thorsten

    Hallo,
    hat jemand eine Idee, wie ich lange Blogbeiträge auf mehrere Seiten verteilen kann? Also nach z.B. 2000 Zeichen soll ein Link zur nächsten Seite angezeigt werden…

    Gruß
    Thorsten

  46. Thorsten

    Hallo,
    ich habe den Blog um den Breadcrump erweitert. Für alle die, die es auch haben möchten: Einfach die blog.php ergänzen…

    Nach der Zeile

    include ('includes/application_top.php');

    Dieses hier einfügen…

    $breadcrumb->add('Blog', xtc_href_link('blog.php'));
    
    if(isset($_GET['blog_cat'])){
    	$kategoriename = xtc_db_fetch_array(xtc_db_query("SELECT titel FROM blog_categories WHERE id = '".(int)$_GET['blog_cat']."' AND language_id = '".(int)$_SESSION['languages_id']."'"));
    
        $breadcrumb->add($kategoriename['titel'], xtc_href_link(FILENAME_BLOG.'?blog_cat='.$_GET['blog_cat']));
        }
    
    if(isset($_GET['blog_item'])){
    	$blogname = xtc_db_fetch_array(xtc_db_query("SELECT name FROM blog_items WHERE id = '".(int)$_GET['blog_item']."' AND language_id = '".(int)$_SESSION['languages_id']."'"));
        $breadcrumb->add($blogname['name'], xtc_href_link(FILENAME_BLOG.'?blog_cat='.$_GET['blog_cat'].'&blog_item='.(int)$_GET['blog_item']));
    }

    Viel Spaß und noch ein schönes Wochenende…
    Thorsten

  47. Pete

    Ich würde das blog gerne für shopstat anpassen, sprich die urls übersetzen lassen. Hat jemand n Tip für mich, wie ich da am besten anfange?

    Gruß Pete

  48. Thorsten

    Hallo zusammen,
    weiß jemand wo ich am besten ansezte, um kategorien und unterkategorien machen kann? Ich hätte gerne weitere Unterkategorien und nicht nur Artikel in den Hauptkategorien.

    Gruß
    Thorsten

  49. Paul Bressel

    Hallo,

    ich habe das Modul installier und soweit funktioniert auch alles. Jedoch zeigt er mir immer eine Fehlermeldung an, wenn ich zb. eine neue Kategorie anlege.

    Warning: Cannot modify header information – headers already sent by (output started at /www/htdocs/w00b0c9c/erfolg-onlineshop.de/inc/xtc_wysiwyg.inc.php:1) in /www/htdocs/w00b0c9c/erfolg-onlineshop.de/admin/includes/functions/general.php on line 130

    Kann mir jemand helfen?

    Vielen Dank….

  50. Daniela Weber

    Tolles Modul. Die Box habe ich im Content Bereich eingebunden.

  51. maxi

    hi paul,
    steht ja alles da…fehler in der general.php in zeile 130 ;-)

    /www/htdocs/w00b0c9c/erfolg-onlineshop.de/admin/includes/functions/general.php on line 130

  52. Thorsten

    Hallo zusammen,

    kann mir jemand sagen, wie ich bei der Kommentarfunktion noch ein zusätzliches Feld einfügen kann? Ich möchte gerne, dass der Kunde dort seinen Namen,eMail und Kommentartext eingeben kann.
    Bitte um Hilfe

    Gruß
    Thorsten

  53. Rene

    @ Thorsten der $breadcrumb ist doppelt …

  54. Thorsten

    @ Rene: Wie meinst Du dass mit doppelt? Auf meiner Seite, oder meinst du doppelt bei meinem Kommentar?

    $breadcrumb->add('Blog', xtc_href_link('blog.php'));

    Macht einen Breadcrumb nach “Startseite” >> “Blog”

    $breadcrumb->add($kategoriename['titel']

    Macht einen zusätzlichen Breadcrumb “Startseite >> Blog >> Kategoriename”

    und

    $breadcrumb->add($blogname['name']

    Lässt dann den Breadcrumb so aussehen: “… >> Blog >> Kategoriename >> Blogüberschrift

    So kann der User wenn er sich auf einer Blogbeitragseite befindet immer in die Hauptkategorie der Seite wechseln und auch auf die Startseite vom Blog…

    Sieht vielleicht nur doppelt aus… ;)

    Kannst Dir das ja mal ansehen: http://www.aquarienfreu.de/blog.php?blog_cat=7&blog_item=23&blog_name=Fotoalbum_November_2010

    Gruß
    Thorsten

  55. lostmail

    Hat das Modul schon mal jemand in einen GAmbio GX Shop eingebaut ?
    hab`s versucht, hat aber leider nicht geklappt da die Teile doch sehr XTC-spezifisch sind…

  56. Timo

    ja ich, man musste bissel schrauben, aber er läuft!

    ich hab selbst einige Anpassungen gemacht, eine separate php-seite und diese eingebunden, anders gabs nur Probleme.

    bitte nicht fragen, was ich alles geändert hab :D

  57. Thorsten

    @lostmail

    Hallo, ich habe ebenfalls das Blogmodul in Gambio eingebaut. Läuft super. Ich habe auch eigentlich keine Anpassungen vorgenommen, außer die hier oben beschriebenen Sachen. Gambio ist ja im Prinzip XTC. Nur etwas erweitert. Ich finde das Blogmodul super. Auf welcher Seite hast Du das Modul denn eingebaut??

    Kannst Dir das ja mal angucken. Und wenn Du Probleme hast, meld Dich einfach nochmal.

    Gruß
    Thorsten

  58. lostmail

    Hi Thorsten,
    hatte das TEil mal versuchweise installiert und dann den kompletten Shop wieder verworfen weil ich zu viele Fehlermeldungen hatte…dachte das paßt einfach nicht zu gambio und ist eher ein reines xt-teil….weiß nicht wo ich da was falsch gemacht hätte.

    Hab mittlerweile wieder einen taufrischen Shop ohne Erweiterungen.

    Wo kann ich mir das mal ansehen ?

  59. Thorsten

    @lostmail

    angucken kannnst Du Dir das Ganze bei http://www.aquarienfreu.de/

    Das Blog-Menü findest Du oben rechts.

    Gruß
    Thorsten

  60. macdanger

    Hallo!

    danke erstmal für das Modul. Ich versuche es gerade testweise zu integrieren und bin recht weit gekommen. Ich hab nur noch 2 Problemchen:

    1) @CHGS: wie muss eine index_blog.php aussehen, damit ich statt der box_BLOG das Inhaltsverzeichnis im content-Bereich habe? Hab schon viel experimentiert, aber keinen richtigen Erfolg gehabt. Deine Implementierung unter http://www.sound-pressure.de/index_blog.php hat mir sehr gut gefallen!

    2) Die Bearbeitung der /includes/modules/metatags.php geht bei mir gar nicht nach Anleitung, sie sieht komplett anders aus. Es ist eine für automatische Metatags. Im header finde ich:

    // --------------------------------------------------------
    // AUTOMATISCHE METATAGS MULTILANGUAGE für xt:Commerce 3.04
    // -------------------------------------------------------
    // by Gunnar Tillmann
    // www,gunnart.de?p=401

    die ist mit der Installationsanleitung so gar nicht kompatibel.

    Wäre echt super, wenn Ihr mir hier noch helfen könntet! Denn das Modul finde ich super und schön überschaubar.

    Viele Grüße
    Markus

  61. Dieter Gotzen

    Ich finde das Blog-Tool super. Jedoch ein vielleicht kleines Problem: auf meiner alten Installation XTC 3.04SP2 gab es keine Probleme. Jetzt unter XT-Modified werden die Bookmarks und Kommentar/Bewertungsmodul nicht angezeigt.

    Hat jemand einen Tipp? Ansonsten läuft nämlich derzeit alles rund.

    LG Dieter

  62. CHGS

    @macdanger

    ist leider schon ein weilchen her, sorry. Ich habe es mit der normalen Installation versucht, hatte Probleme mit anderen Modifikationen. Habe daher glaub die index.php datei kompiert und darin den Blog eingebunden …

    im Hauptverzeichnis liegt die blog.php und index_blog.php (diese zieht die Template-Datei Shop_Blog.html an).

    blog.php

    Code entfernt
    Grosse Codepassagen bitte im Forum posten, denn genau für solche Diskussionen wurde es eingerichtet.

    weis nicht, ob dir das hilft.

  63. ebookshop

    hi dieter,
    ich habe auch noch eine “alte” XTC 3.04SP2 am laufen und habe eine xt-modified am testen, und es gab beim “überspielen” der datenbank echte probleme, du müßtest deine zwei datenbanken saven (die alte + neue) und dann die blog-einträge der neuen datenbank löschen und die blog-einträge der alten in die neue datenbank übertragen. liegt mitsicherheit daran. die datenbank von xt-modified wurde geändert und es gibt keine 100% kompatibilität.

    gruß maxi aus frankfurt

  64. Dieter Gotzen

    Hallo Maxi,

    also die Kommentarfunktion krieg ich nicht hin. Egal wo die Einträge in der blog.html gesetzt werden, es wird nix angezeigt. Dafür habe ich das mit den Bookmarks halbwegs elegant gelöst.

    Grüße aus Hückeswagen

    Dieter

  65. Oliver

    Hallo,

    habe seit kurzem ein Problem. Keiner kann mehr einen Kommentar schreiben. Habe in den Einstellungen schon geschaut, alles i.O. Einer ne Idee was es noch sein könnte?

  66. phil

    Hallo zusammen,
    das Blogmodul ist super und einfach zu installieren, wie kann ich den Namen des Users, der ein Kommentar schreibt nur mit seinen Initialen veröffentlichen z.B Paul M… statt Paul Mustermann.
    Grüße aus Berlin

  67. phil

    Hallo nochmal,
    hat keiner ein Tipp wo ich das im Script ändern kann?
    Grüße aus Berlin

  68. Sylvio

    Folgendes Problem. Leider wird die Blog-ID nicht in die Datenbank geschrieben, wenn jemand einen Kommentar abgibt. Dadurch erscheinen also auch keine Kommentare mehr im Blog… Finde zum Verrecken den Fehler nicht. Hat jemand einen Lösungsansatz woran es liegen kann? Danke im Voraus.

  69. Sylvio

    Problem gelöst: Blog-ID wird nicht in die Datenbank geschrieben.

    Eigentlich ganz klar und einfach. Im Script blog_comment.php stand bei mir statt $_POST[‘blog_id’] nur $blog_id. Und $blog_id war natürlich leer. Also so ist’s nun richtig:

    xtc_db_query("INSERT into blog_comment (id,blog_id,name,text,date) VALUES ('".$next_id."','".xtc_db_prepare_input($_POST['blog_id'])."'
  70. Sven

    Hallo,

    es wird beschreben “im Hauptverzeichnis liegt die blog.php und index_blog.php”, doch die index_blog.php ist nicht im Zip-File. Kann die jemand zur Verfügung stellen. Weiterhin scheint das RSS nicht richtig zu funktionieren. Gerade in Verbindung mit RSSgraffiti. Hat hier jemand Erfahrung?

    Gruß

    Sven

  71. Andre

    Hallo!

    Ich habe nun den Blog wie beschrieben installiert. Ich sehe zwar im Adminbereich den Punkt “BLOG”. Leider hier nur

    TABLE_HEADING_NAVIGATION TABLE_HEADING_NAVIGATION_OVERVIEW TABLE_HEADING_NAVIGATION_NEWCATEGORIE
    usw.

    Keine Beschreibungen etc.

    Ich habe alles lt. Beschreibung gemacht sprich auch in die index.html etc. eingebaut. Aber im Shop wird nichts angezeigt?!
    Wäre lieb wenn mir jemand behilflich ist.

  72. Adam

    Hi,

    hab gerade etwas Zeit mit der Frage warum die blog_rss.php nicht funktioniert verbracht. Die Lösung sind die Sonderzeichen.

    In Zeile 7 und 9 müssen die Umlaute raus und diese Zeile muss nach Zeile 74 eingefügt werden

    $link = str_replace ("&", "&amp;", $link);

    Dann sollte es laufen.

  73. Oli

    Hallo zusammmen,

    erst mal einen herzlichen Dank für die ganze Arbeit an die edlen Spender dieser Software!!
    Läuft bestens, habe da nur noch ein Positionierungsproblem mit dem Themenbereich und brauche hierfür Eure Hilfe.
    Das Thema wird bei mir erst unterhalb der Boxen angezeigt und soll wie bei der Ansicht der Kategorien allerdings nach oben rücken.
    Ich hab vieles ausprobiert, bekomm es aber nicht hin. Kann mir jemand weiterhelfen, an welcher Schraube zu drehen ist?
    Website: http://www.plpa.de

    DANKE schon im Voraus…
    Ich hoffe doch sehr, dass noch jemand hier ist??…:-)

    Gruß
    Oli

  74. Oli

    OK…hab da was gefunden.
    Habe in der blog.html den style von clear:both auf clear:none gesetzt. Funktioniert soweit und noch kann ich keinen Nachteil erkennen.
    Wer kennt denn einen??…:-)

  75. DoroM

    hallo, ich habe den Blog eingebunden. Dabei habe ich in der Blog-Box die Blogeinträge auf display:none gestellt, damit man nur die Kategorien in der Navigation sieht.
    Es gibt aber noch Probleme: in der Breadcrumb ist “blog” doppelt und die Sortierung innerhalb der Kategorien ist nicht immer chronologische. Was könnte das sein?

  76. Steffen

    Ich habe exakt die gleiche bisher unbeantwortete Frage wie Andre/Nr.71 zur Installation des Blog Moduls in ein GX2:

    Nach der Installation wird im Admin Bereich unter Blog

    TABLE_HEADING_NAVIGATION TABLE_HEADING_NAVIGATION_OVERVIEW TABLE_HEADING_NAVIGATION_NEWCATEGORIE

    angezeigt.

    Wer eine Idee hat, bitte mal posten.

  77. Kehrer
    else {
    ?>
    <meta name="description" content="" />
    <meta name="keywords" content="" />
    
    <?php
    
    		}

    gibt es bei mir nicht.

    habe die metatags von hier. Wo kann ich dass dann einschreiben?
    Brauch ich das else überhaupt?

  78. Dietrich Florentina

    In meine shop xtcommerce finde ich nicht diese datei,existiert nicht
    /templates/IHR_TEMPLATE/general.js.php
    diese general.js.php gibt’s in meine shop nicht
    Ist das möglich oder ist für andre version andwenbar

  79. Kehrer

    @Florentina:

    templates/IHR_TEMPLAT/javascript/
    hier ist die general.js

  80. Dietrich Florentina

    Danke

  81. Gameserver Freak

    Super Modul, nur kann man vielleicht einstellen das in der Box nur die Blogkategorieen angezeigt werden oder kann man die Beitragsanzahl die in der Box angezeigt werden sollen einstellen?

  82. uncut games

    Nach so einer Lösung für XTC hab ich lange gesucht. Der Einbau klappte prima. Vielen dank für das gute Modul.
    Grüße von der Küste

  83. Kehrer

    Warum werden bei mir die Sternchen nicht angezeigt?
    Wa werden die aufgerufen?
    Auch das datum wird nicht als Kalender angezeigt.
    Die Bilder habe ich aber alle korrekt hochgeladen.

  84. Marco

    Danke für das tolle Modul! Die Einbindung war sehr einfach, lediglich das Design der Box muss individuell angepasst werden. Super und vielen Dank.

  85. Claudio

    Leider wurde mein Shop von einem Virus infiziert und es wurde die hier angebotene Erweiterung betroffen. Gibt es einen Patch?

    Der Name des Virus: JS/BlacoleRef.DD.17

  86. geri

    Hat jemand Erfahrung damit, ob das unter xt:c 4.1 auch ordentlich läuft?

    Merci für eine Antwort

Kommentar schreiben

Hier findest Du Platz für Deine Meinung, Dein Lob, Deine Kritik. Bitte nutze diese Funktion nicht für Supportanfragen! Wenn Du Fragen zu Modulen, Fehlermeldungen oder ähnliches hast, bist Du in unserem eCommerce-Forum herzlich willkommen.

© 2005 - 2015 by xtc-load.de